summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyregion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyregion')
-rw-r--r--dev-python/pyregion/Manifest2
-rw-r--r--dev-python/pyregion/metadata.xml12
-rw-r--r--dev-python/pyregion/pyregion-1.1.2.ebuild32
-rw-r--r--dev-python/pyregion/pyregion-1.1.4.ebuild32
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pyregion/Manifest b/dev-python/pyregion/Manifest
new file mode 100644
index 000000000000..88ea05506c9f
--- /dev/null
+++ b/dev-python/pyregion/Manifest
@@ -0,0 +1,2 @@
+DIST pyregion-1.1.2.tar.gz 98664 SHA256 7a21f461ffd4f9f3eea1fe254b3176a99f32a54c83bc3053bdc80425d0368cda SHA512 fd8573744d884b6711ca0cb398fb9eaa4294ebbae3fccd70ec74fd2b41f8302c9c84ebbcf83b7cdd064192f36e3fe8fa3b03d8d329ecce89e62f0695b31cdce7 WHIRLPOOL 95f32b414f6485fbb5028dfc3307d801d6b5e970292225189710b1d95a1effc9f1537419487dffcb7b34adb537098a902fe735f69956dce112f15fcebc5123a4
+DIST pyregion-1.1.4.tar.gz 99454 SHA256 2d7d5ce46a3b4177978d4901c9c46ce402165113049006b923f5346b014973b9 SHA512 572a10593dc93f64ad6fd1d7a8f19582df04309b88a73fb41e3b4c71036d61c3857114cc01025e581ddd3a63af92fabb5375c1ee8fe487f83da2780569954236 WHIRLPOOL 54791087d514e9c4b0e850c77219ed4d453a2a86c148ce04f2dc8cbcdc9138e075860acc6c2812e9033cfe15cca2b093d792186a2b47f903c747d2486feab8bd
diff --git a/dev-python/pyregion/metadata.xml b/dev-python/pyregion/metadata.xml
new file mode 100644
index 000000000000..b515cba0ba5d
--- /dev/null
+++ b/dev-python/pyregion/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ pyregion is a python module to parse ds9 region files. It also
+ support ciao region files, and can draw regions using matplotlib.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">pyregion</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/pyregion/pyregion-1.1.2.ebuild b/dev-python/pyregion/pyregion-1.1.2.ebuild
new file mode 100644
index 000000000000..58ccdaabf307
--- /dev/null
+++ b/dev-python/pyregion/pyregion-1.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Python module to parse ds9 region file"
+HOMEPAGE="http://leejjoon.github.com/pyregion/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT"
+
+IUSE="examples"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ || ( dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pyrex[${PYTHON_USEDEP}] )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/pyregion/pyregion-1.1.4.ebuild b/dev-python/pyregion/pyregion-1.1.4.ebuild
new file mode 100644
index 000000000000..58ccdaabf307
--- /dev/null
+++ b/dev-python/pyregion/pyregion-1.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Python module to parse ds9 region file"
+HOMEPAGE="http://leejjoon.github.com/pyregion/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT"
+
+IUSE="examples"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ || ( dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pyrex[${PYTHON_USEDEP}] )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}