summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 18:23:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 18:24:24 -0500
commitf232f49f2edfab0276945cf4c11e1031c0b30679 (patch)
tree2d03f0d15e0024cce01c2bc5b2b522a4349af36d /dev-python/pyroute2
parentdev-python/stestr: adding DISTUTILS_USE_SETUPTOOLS=rdepend (diff)
downloadgentoo-f232f49f2edfab0276945cf4c11e1031c0b30679.tar.gz
gentoo-f232f49f2edfab0276945cf4c11e1031c0b30679.tar.bz2
gentoo-f232f49f2edfab0276945cf4c11e1031c0b30679.zip
dev-python/pyroute2: 0.5.14 bump
Closes: https://bugs.gentoo.org/748384 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/pyroute2-0.5.14.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
index c443a6dcaa4a..1f7845b9dae4 100644
--- a/dev-python/pyroute2/Manifest
+++ b/dev-python/pyroute2/Manifest
@@ -1 +1,2 @@
DIST pyroute2-0.5.12.tar.gz 425500 BLAKE2B 2b8f919bc7fc9caea9f4dd41b110e8a321406de998598408bbd12d6d62fcae009d01511271e462a4118311f12c54bf51696c0334da2ce9cb185688e35994b0a8 SHA512 6115826a43f6392a727fe2dde0dd24317f35c3a7af5e45459766c3fbe9853540c68f9a9a2233c266e866f3decd22dab0032117f687758f69b962ac6606d4cbdf
+DIST pyroute2-0.5.14.tar.gz 436853 BLAKE2B 9febcd6563d89b5ffd71342d8d83a3251494f978ad4449532b568cf0929c9f3d8d8d36e1a0b0f6733013e12f6322aea46d991a22f5c3fa93e47dfa08376ddd13 SHA512 9601cf8133b703c55770b6292cca1e907a029689aaeb350b6eee40406b56de5563ee0ba37b4814540c365a5974be78a024dcb27bc7ee00eac74676f4013cf277
diff --git a/dev-python/pyroute2/pyroute2-0.5.14.ebuild b/dev-python/pyroute2/pyroute2-0.5.14.ebuild
new file mode 100644
index 000000000000..2c8bef309349
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.5.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library."
+HOMEPAGE="https://github.com/svinota/pyroute2"
+SRC_URI="https://github.com/svinota/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-python/psutil[${PYTHON_USEDEP}] )"
+
+RESTRICT="!test? ( test )"
+
+# tests need root access
+RESTRICT+=" test"
+
+PATCHES=(
+ "${FILESDIR}/pyroute2-0.5.12-readme-filename.patch"
+)
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ sed -i "s/^release.*/release := ${PV}/" Makefile || die
+ distutils-r1_python_prepare_all
+}