summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-15 08:54:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-15 09:23:34 +0200
commit1214e7279996b45eccd679447be58d05afcb129c (patch)
tree6456bcad7708a4df99cbd85400c3efaf1d903aef /dev-python/pyrsistent
parentdev-python/dbutils: add 3.0.2 (diff)
downloadgentoo-1214e7279996b45eccd679447be58d05afcb129c.tar.gz
gentoo-1214e7279996b45eccd679447be58d05afcb129c.tar.bz2
gentoo-1214e7279996b45eccd679447be58d05afcb129c.zip
dev-python/pyrsistent: add 0.18.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyrsistent')
-rw-r--r--dev-python/pyrsistent/Manifest1
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.18.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/Manifest b/dev-python/pyrsistent/Manifest
index 2401184a4bef..bd3df50de8df 100644
--- a/dev-python/pyrsistent/Manifest
+++ b/dev-python/pyrsistent/Manifest
@@ -1 +1,2 @@
DIST pyrsistent-0.18.0.tar.gz 104215 BLAKE2B 028c26a6b4bcaa8c3e3e1ad1748a6b45f664355c66f0f97c70e4d26c66946a55b346d0340c2e697e9890039692580c03032055cab7c198c39530e5561be83801 SHA512 f56062430f914a884a9317ecf5278ccc09d98f1d6867716f89173db47996b8d4c1ef4f5c0121c955d81fc4fe8aba7d30f38679baea6208168c3952846064cfeb
+DIST pyrsistent-0.18.1.tar.gz 100522 BLAKE2B 75632d254993666076a68d81b8b5a7aced8601146fed5cd63f1d56c5e0578650a197aca7630855de32a8447eab972203aa7d83009398f96e6f374c0a4b2cc1ba SHA512 353ad6e9165e1afdde37730a9289cf8dde28491abb688d702a8c8f5279e24f5ce387a5d00ac4a077322299f9c1a535781bcacdcd1cb914ddb317b3ca9641778b
diff --git a/dev-python/pyrsistent/pyrsistent-0.18.1.ebuild b/dev-python/pyrsistent/pyrsistent-0.18.1.ebuild
new file mode 100644
index 000000000000..e573b42db8e5
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.18.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="https://github.com/tobgu/pyrsistent/ https://pypi.org/project/pyrsistent/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest