summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-17 16:30:34 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-17 16:53:45 -0500
commit12a67c9621b22facaa542083029c85356b7bff15 (patch)
tree73433311610a59f6ed23116a92993cb982249ee9 /dev-python/pysaml2/pysaml2-6.1.0.ebuild
parentdev-python/oslo-messaging: 12.5.0 bump (diff)
downloadgentoo-12a67c9621b22facaa542083029c85356b7bff15.tar.gz
gentoo-12a67c9621b22facaa542083029c85356b7bff15.tar.bz2
gentoo-12a67c9621b22facaa542083029c85356b7bff15.zip
dev-python/pysaml2: 6.1.0 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pysaml2/pysaml2-6.1.0.ebuild')
-rw-r--r--dev-python/pysaml2/pysaml2-6.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pysaml2/pysaml2-6.1.0.ebuild b/dev-python/pysaml2/pysaml2-6.1.0.ebuild
new file mode 100644
index 000000000000..3be144be98eb
--- /dev/null
+++ b/dev-python/pysaml2/pysaml2-6.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of SAML Version 2 to be used in a WSGI environment"
+HOMEPAGE="https://github.com/rohe/pysaml2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-1.4[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"