summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-29 17:34:49 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-29 17:40:10 +0200
commit95e249b0ffdd12a5c8818e3f5e7c583ccfd04158 (patch)
tree612c1b1bb523eb3c29011d621663e0a0476c483d /dev-python/pysendfile
parentdev-python/pysendfile: fix DESCRIPTION (diff)
downloadgentoo-95e249b0ffdd12a5c8818e3f5e7c583ccfd04158.tar.gz
gentoo-95e249b0ffdd12a5c8818e3f5e7c583ccfd04158.tar.bz2
gentoo-95e249b0ffdd12a5c8818e3f5e7c583ccfd04158.zip
dev-python/pysendfile: add tests, Python 3.7, PyPy3, EAPI=7
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/pysendfile')
-rw-r--r--dev-python/pysendfile/pysendfile-2.0.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pysendfile/pysendfile-2.0.1-r1.ebuild b/dev-python/pysendfile/pysendfile-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..6add938cfbae
--- /dev/null
+++ b/dev-python/pysendfile/pysendfile-2.0.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python interface to the sendfile(2) system call"
+HOMEPAGE="https://github.com/giampaolo/pysendfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc64 ~sparc ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" test/test_sendfile.py || die "tests failed with ${EPYTHON}"
+}