summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pysfml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pysfml')
-rw-r--r--dev-python/pysfml/Manifest1
-rw-r--r--dev-python/pysfml/metadata.xml8
-rw-r--r--dev-python/pysfml/pysfml-1.6-r1.ebuild41
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pysfml/Manifest b/dev-python/pysfml/Manifest
new file mode 100644
index 000000000000..376926f79182
--- /dev/null
+++ b/dev-python/pysfml/Manifest
@@ -0,0 +1 @@
+DIST SFML-1.6-python-sdk.zip 170889 SHA256 1c6808bffb2e7346f6ca44e778245412427f21d59940dfd37088149e6557cd33 SHA512 e43aecd95cde10578ffc4f2eaf352efcc42983ff4edd7c30aebdb3c15c73cf5a261d61dda544a726fcfc7d6946d73d6b6de99896e4d9b3c3d8e8ff7166ee2a59 WHIRLPOOL feb2e80c274a2af3ec918326adbc20f0a1df926f2c6d471c3fa3c5f8182b83c3bbb4496d2b0585a656021e1210b6180f9720b4e03584a0f9ce35c4861c8de1a1
diff --git a/dev-python/pysfml/metadata.xml b/dev-python/pysfml/metadata.xml
new file mode 100644
index 000000000000..6a4b06827515
--- /dev/null
+++ b/dev-python/pysfml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">sfml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pysfml/pysfml-1.6-r1.ebuild b/dev-python/pysfml/pysfml-1.6-r1.ebuild
new file mode 100644
index 000000000000..a0d2abe206f7
--- /dev/null
+++ b/dev-python/pysfml/pysfml-1.6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for the Simple and Fast Multimedia Library (SFML)"
+HOMEPAGE="http://sfml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sfml/SFML-${PV}-python-sdk.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="~media-libs/libsfml-${PV}"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/SFML-${PV}/python
+
+python_compile() {
+ if [[ ${EPYTHON} == python2* ]] ; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml doc/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "doins failed"
+ fi
+}