summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-05-16 22:56:42 -0400
committerRick Farina <zerochaos@gentoo.org>2019-05-16 22:56:52 -0400
commita4137aad161c836126d37d63ef2756bb089ef076 (patch)
tree3d96367a0dcdb88da823d649082262ce9f661365 /dev-python/pyshark
parentapp-text/mupdf: arm64 stable (diff)
downloadgentoo-a4137aad161c836126d37d63ef2756bb089ef076.tar.gz
gentoo-a4137aad161c836126d37d63ef2756bb089ef076.tar.bz2
gentoo-a4137aad161c836126d37d63ef2756bb089ef076.zip
dev-python/pyshark: bump and dep fix
bug #683686 bug #683682 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/pyshark')
-rw-r--r--dev-python/pyshark/Manifest1
-rw-r--r--dev-python/pyshark/pyshark-0.3.7.2-r1.ebuild (renamed from dev-python/pyshark/pyshark-0.3.7.2.ebuild)2
-rw-r--r--dev-python/pyshark/pyshark-0.4.2.3.ebuild49
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/pyshark/Manifest b/dev-python/pyshark/Manifest
index 498f737dfc17..fddea2e21391 100644
--- a/dev-python/pyshark/Manifest
+++ b/dev-python/pyshark/Manifest
@@ -1 +1,2 @@
DIST pyshark-0.3.7.2.tar.gz 27232 BLAKE2B b93ee24fb29990b0ab455935e773e4844c26761c2515d1254c8e72d24d70be95aa17a590cc1f5b39bb5f76db624fb7c40d06e64731948ee75a5b8e2008830968 SHA512 dbd97665fae7d3067582bf7616e025b0c5e5fa14cacdaca59c89b4e70feb3017f2d8c7d899a70c0c8707589e4735b9283914bb6ccbf432e9072c64d7e957bc15
+DIST pyshark-0.4.2.3.tar.gz 29363 BLAKE2B 91463f725eb893c3c7f7442eec5e0a8304bb8f2ecbd0ea80582c49bfd8538a5fcdb1d5d1ab2373f8e67684c78c8852af697dadf8ff041d42f8ff18a8954a6248 SHA512 bbef857dad5e5141e0ec7c04dba9faca81b17d67a7151959e9935577428cd1415e173e9c7ededff46f8621bcbbdfbe7a96ca5cfd65d7143fb6f235c0167964b6
diff --git a/dev-python/pyshark/pyshark-0.3.7.2.ebuild b/dev-python/pyshark/pyshark-0.3.7.2-r1.ebuild
index a2ebdaf0d066..761cfea65af2 100644
--- a/dev-python/pyshark/pyshark-0.3.7.2.ebuild
+++ b/dev-python/pyshark/pyshark-0.3.7.2-r1.ebuild
@@ -25,7 +25,7 @@ RDEPEND="
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/trollius[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
- net-analyzer/wireshark"
+ net-analyzer/wireshark[tshark]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
diff --git a/dev-python/pyshark/pyshark-0.4.2.3.ebuild b/dev-python/pyshark/pyshark-0.4.2.3.ebuild
new file mode 100644
index 000000000000..5e6234567d6c
--- /dev/null
+++ b/dev-python/pyshark/pyshark-0.4.2.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python wrapper for tshark output parsing"
+HOMEPAGE="https://pypi.org/project/pyshark/ https://github.com/KimiNewt/pyshark"
+# pypi tarball is missing tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/KimiNewt/pyshark/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# See pyshark.egg-info/requires.txt
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/logbook[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/trollius[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ net-analyzer/wireshark[tshark]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${P}/src"
+
+python_prepare_all() {
+ # Test fails unless portage can execute /usr/bin/dumpcap
+ # https://github.com/KimiNewt/pyshark/issues/197
+ rm "${WORKDIR}/${P}/tests/capture/test_inmem_capture.py" || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ py.test -v || die
+}