summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pystache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pystache')
-rw-r--r--dev-python/pystache/Manifest2
-rw-r--r--dev-python/pystache/metadata.xml14
-rw-r--r--dev-python/pystache/pystache-0.5.3.ebuild27
-rw-r--r--dev-python/pystache/pystache-0.5.4.ebuild28
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/pystache/Manifest b/dev-python/pystache/Manifest
new file mode 100644
index 000000000000..b481d0b27caa
--- /dev/null
+++ b/dev-python/pystache/Manifest
@@ -0,0 +1,2 @@
+DIST pystache-0.5.3.tar.gz 74827 SHA256 445c8663291abf11305693ecac7b9f3ff976555f5506ccc05a0353260a5a16dc SHA512 2b77f3e26cf37e663b7414e5ca95667f8332bb1005ae835775543c0d2c282f0c7bd8ded3f1e06da930247e39e5d206fb3f90d80e7c556b98cd69d4be74836843 WHIRLPOOL ae6ff420d95c36e61c7e95f12dcfb0ef18c7fc9f114b250a9cecda86fafa0acd66d959fbfe47802d0558fcce929c5be89f5d0c5f76a8bac08e26078a60766ef7
+DIST pystache-0.5.4.tar.gz 75131 SHA256 f7bbc265fb957b4d6c7c042b336563179444ab313fb93a719759111eabd3b85a SHA512 4ac325e1431f58f740218c9ec309821db82d89989ef4ca7fc3536dea0ef1c90e8e85ebaa7df27f33129ca02252b84bcbd7429a1ed999b496f62f174dd66502cb WHIRLPOOL ced73b06095323eb56f215aa68517ea32b8b4ba51b34ab71c861d09bdebbae91e6b05ed162a75592e40f5d18691a5df16e3dd1678789c4e6c4ccee2789201cbd
diff --git a/dev-python/pystache/metadata.xml b/dev-python/pystache/metadata.xml
new file mode 100644
index 000000000000..c03b50fc09d3
--- /dev/null
+++ b/dev-python/pystache/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ Pystache is a Python implementation of Mustache.
+ Mustache is a framework-agnostic, logic-free
+ templating system for Ruby, inspired by ctemplate and etc.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">pystache</remote-id>
+ <remote-id type="github">defunkt/pystache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pystache/pystache-0.5.3.ebuild b/dev-python/pystache/pystache-0.5.3.ebuild
new file mode 100644
index 000000000000..c27a4e96dd53
--- /dev/null
+++ b/dev-python/pystache/pystache-0.5.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+inherit distutils-r1
+
+DESCRIPTION="Mustache for Python"
+HOMEPAGE="http://github.com/defunkt/pystache"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib
+ nosetests || die
+}
diff --git a/dev-python/pystache/pystache-0.5.4.ebuild b/dev-python/pystache/pystache-0.5.4.ebuild
new file mode 100644
index 000000000000..909ec70a2433
--- /dev/null
+++ b/dev-python/pystache/pystache-0.5.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Mustache for Python"
+HOMEPAGE="http://github.com/defunkt/pystache"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ nosetests || die
+ popd > /dev/null
+}