summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 19:40:23 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 19:40:36 +0200
commit7ec43f6bed3b814f54526421bab8ef0cf2320287 (patch)
tree15d2056904df1e878a6625fd2a9843487f21055e /dev-python/pystatgrab/pystatgrab-0.7.ebuild
parentdev-python/strict-rfc3339: Bump (diff)
downloadgentoo-7ec43f6bed3b814f54526421bab8ef0cf2320287.tar.gz
gentoo-7ec43f6bed3b814f54526421bab8ef0cf2320287.tar.bz2
gentoo-7ec43f6bed3b814f54526421bab8ef0cf2320287.zip
dev-python/pystatgrab: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/pystatgrab/pystatgrab-0.7.ebuild')
-rw-r--r--dev-python/pystatgrab/pystatgrab-0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pystatgrab/pystatgrab-0.7.ebuild b/dev-python/pystatgrab/pystatgrab-0.7.ebuild
new file mode 100644
index 000000000000..9f028a311560
--- /dev/null
+++ b/dev-python/pystatgrab/pystatgrab-0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION=" pystatgrab is a set of Python bindings for the libstatgrab library"
+HOMEPAGE="http://www.i-scream.org/pystatgrab/"
+SRC_URI="http://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/pystatgrab/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/libstatgrab-0.91"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" test.py || die
+}