summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-07-14 15:37:21 -0700
committerPatrice Clement <monsieurp@gentoo.org>2016-08-30 17:29:30 +0200
commitf91bd4a5dac8cb786cb607dd75b8cce8514c2c24 (patch)
treed291dd9911e0eecd8fec0a313b548fca097e3d79 /dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild
parentapp-vim/nginx-syntax: add ~x86-fbsd keyword. (diff)
downloadgentoo-f91bd4a5dac8cb786cb607dd75b8cce8514c2c24.tar.gz
gentoo-f91bd4a5dac8cb786cb607dd75b8cce8514c2c24.tar.bz2
gentoo-f91bd4a5dac8cb786cb607dd75b8cce8514c2c24.zip
app-misc/openastro{,-data}, dev-python/pyswisseph: new package.
openastro is an open source astrology program written in Python. Gentoo-Bug: https://bugs.gentoo.org/586110 Closes: https://github.com/gentoo/gentoo/pull/1888 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild')
-rw-r--r--dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild b/dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild
new file mode 100644
index 000000000000..29623a0b68fa
--- /dev/null
+++ b/dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_PV=${MY_PV}-${PLEVEL}
+
+DESCRIPTION="Python extension to the AstroDienst Swiss Ephemeris"
+HOMEPAGE="https://github.com/astrorigin/pyswisseph"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/astrorigin/pyswisseph.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"