summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pysyck
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pysyck')
-rw-r--r--dev-python/pysyck/Manifest1
-rw-r--r--dev-python/pysyck/metadata.xml13
-rw-r--r--dev-python/pysyck/pysyck-0.61.2-r1.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pysyck/Manifest b/dev-python/pysyck/Manifest
new file mode 100644
index 000000000000..4ba52ae1977e
--- /dev/null
+++ b/dev-python/pysyck/Manifest
@@ -0,0 +1 @@
+DIST PySyck-0.61.2.tar.gz 44949 SHA256 cc4ce350411c39d11a4654d8e97f5f92644c3dd9a1e2e2d862f3de47190ed473 SHA512 3ccb304b7a8efbf57209079b92fb34f0122cb1da93ee51fb45bdd5e8728dec383e0e0e9f329f1704ef5deeb6cdb93a5dc9cad69c877a886e9d0c3058ec1aa812 WHIRLPOOL d98d43ead9a6b196f567f78b8b0ccce8d5ac1df222531e478c8645a58dfeadfe5bef9c4b89660fe1a72802899dc14361ca6c04f6beeab747f4d838852eb74cb1
diff --git a/dev-python/pysyck/metadata.xml b/dev-python/pysyck/metadata.xml
new file mode 100644
index 000000000000..a55e575513b5
--- /dev/null
+++ b/dev-python/pysyck/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ PySyck is aimed to update the current Python bindings for Syck. The new
+ bindings provide a wrapper for the Syck emitter and give access to YAML
+ representation graphs. PySyck may be used for various tasks, in
+ particular, as a replacement of the module pickle.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pysyck/pysyck-0.61.2-r1.ebuild b/dev-python/pysyck/pysyck-0.61.2-r1.ebuild
new file mode 100644
index 000000000000..9cad1c0be052
--- /dev/null
+++ b/dev-python/pysyck/pysyck-0.61.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="PySyck-${PV}"
+
+DESCRIPTION="Python bindings for the Syck YAML parser and emitter"
+HOMEPAGE="http://pyyaml.org/wiki/PySyck"
+SRC_URI="http://pyyaml.org/download/pysyck/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/syck-0.55"
+RDEPEND="${DEPEND}"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${PYTHON}" tests/test_syck.py
+ einfo "Some tests may have failed due to pending bugs in dev-libs/syck"
+}