summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 13:16:55 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 13:58:15 +0200
commit667b0f9ed66f0e45d7193a5279181a5811e9495c (patch)
tree188d7cdc2385aeb5ed9510c215ced1ae64229e5c /dev-python/pytables/pytables-3.2.1.ebuild
parentdev-python/flask-pymongo: Clean old versions up (diff)
downloadgentoo-667b0f9ed66f0e45d7193a5279181a5811e9495c.tar.gz
gentoo-667b0f9ed66f0e45d7193a5279181a5811e9495c.tar.bz2
gentoo-667b0f9ed66f0e45d7193a5279181a5811e9495c.zip
dev-python/pytables: Clean old versions up
Diffstat (limited to 'dev-python/pytables/pytables-3.2.1.ebuild')
-rw-r--r--dev-python/pytables/pytables-3.2.1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/pytables/pytables-3.2.1.ebuild b/dev-python/pytables/pytables-3.2.1.ebuild
deleted file mode 100644
index 881c844dd985..000000000000
--- a/dev-python/pytables/pytables-3.2.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-MY_PN=tables
-MY_P=${MY_PN}-${PV}
-
-inherit distutils-r1
-
-DESCRIPTION="Hierarchical datasets for Python"
-HOMEPAGE="http://www.pytables.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="BSD"
-IUSE="doc examples"
-
-RDEPEND="
- app-arch/bzip2:0=
- dev-libs/c-blosc:0=[hdf5]
- dev-libs/lzo:2=
- >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
- >=dev-python/numexpr-2.4[${PYTHON_USEDEP}]
- >=sci-libs/hdf5-1.8.4:0="
-DEPEND="${RDEPEND}
- >=dev-python/cython-0.14[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( ANNOUNCE.txt RELEASE_NOTES.txt THANKS )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.2.0-blosc.patch
- )
-
-python_prepare_all() {
- export HDF5_DIR="${EPREFIX}"/usr
- sed \
- -e "s:/usr:${EPREFIX}/usr:g" \
- -e 's:"c-blosc/hdf5/blosc_filter.c"::g' \
- -i setup.py || die
- rm -r c-blosc/{blosc,hdf5,internal-complibs} || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- ${EPYTHON} tables/tests/test_all.py || die
-}
-
-python_install_all() {
- if use doc; then
- HTML_DOCS=( doc/html/. )
- DOCS+=( doc/scripts )
- fi
- distutils-r1_python_install_all
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- doins -r contrib
- fi
-}