summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-12 10:44:08 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-12 10:44:18 +0100
commit13653306e47d78d390af060c28674df66a94e3d0 (patch)
tree7d8bac7afbdc6690658bee209623a6c9fc5a3f87 /dev-python/pyte
parentdev-python/curtsies: Version Bump (diff)
downloadgentoo-13653306e47d78d390af060c28674df66a94e3d0.tar.gz
gentoo-13653306e47d78d390af060c28674df66a94e3d0.tar.bz2
gentoo-13653306e47d78d390af060c28674df66a94e3d0.zip
dev-python/pyte: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyte')
-rw-r--r--dev-python/pyte/Manifest1
-rw-r--r--dev-python/pyte/pyte-0.5.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyte/Manifest b/dev-python/pyte/Manifest
index 9bec2a5f81a8..d6a6e4ed2e59 100644
--- a/dev-python/pyte/Manifest
+++ b/dev-python/pyte/Manifest
@@ -1,2 +1,3 @@
DIST pyte-0.4.10.tar.gz 44410 SHA256 9c492bacc628c2e88fe3a5cb70dcd361b544baa46cd51435861e48068a896ecf SHA512 64ee60285c621cf13e24bb7e22e541bb66ed4eb2fa5cb371e0051d65e96766ae630c15206b0f0ee3f98dff87a82517b65dd9b322445439d97a92dd226a54969f WHIRLPOOL bd7f1526cf58e4ba31236d8d7f4f7e352110a70c155dfdf21b84b497262f9e8106f5efbdc30e42733cd27f9e430322ab4fceaec8f18267e09b7ccc0ea52636fb
DIST pyte-0.4.9.tar.gz 43730 SHA256 3b1d3b9df29e24f6ae3e9c277d830a01bbb610bf88e6bb4c8255a25c00472ba3 SHA512 551f464282db7bd4eadf53358619651a6bac59868939f30ee3f33255a275ec321d773c075e786f28861824ed005282ec7aac11a63ced173fe8a1aacbfa9e2e0c WHIRLPOOL 20eac26136cdc906d40ea0b409be99959443fd2b24143a29223f78f42986f52f4e4b99c0817a22ed0edcf2b59e1d5961fac0cf4cc32d1430f71f64b532b9e951
+DIST pyte-0.5.1.tar.gz 49849 SHA256 d2cf77ef6395c6b97d5c10ee47f38d348114170e504fc55a043d4c7dd1aea6e1 SHA512 7077af73b91a990b03689b49172f2ec4ece98f132021bac2c3adbf1a61d7b868acdb400400bb43bb51ce3873cb9a5dc365662e0689cebf058151476c8cb69e9b WHIRLPOOL 5b79a96e45183d9ff6c0f7ac9a16be0eb96cad1a9e4bf48077992a55f4cce3c53e135d3c0befb8106115538825c4625d1467ecd70f728fcfc9c797662b6e72d7
diff --git a/dev-python/pyte/pyte-0.5.1.ebuild b/dev-python/pyte/pyte-0.5.1.ebuild
new file mode 100644
index 000000000000..587dd2af29ae
--- /dev/null
+++ b/dev-python/pyte/pyte-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="https://pypi.python.org/pypi/pyte/ https://github.com/selectel/pyte"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # no need for benchmarking
+ rm tests/test_benchmarks.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test --verbose
+}