summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-21 21:08:41 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-21 21:08:51 +0200
commit8dcd3baa215d73b67bd64b10862d5f8e6fa9c2e5 (patch)
treeb1e776ae2bd7d2ebcff9b3c6a9748ad47caadab2 /dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild
parentdev-python/berkeleydb: add 18.1.5 (diff)
downloadgentoo-8dcd3baa215d73b67bd64b10862d5f8e6fa9c2e5.tar.gz
gentoo-8dcd3baa215d73b67bd64b10862d5f8e6fa9c2e5.tar.bz2
gentoo-8dcd3baa215d73b67bd64b10862d5f8e6fa9c2e5.zip
dev-python/pytest-aiohttp: add 1.0.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild')
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild
new file mode 100644
index 000000000000..6f2f5b8373a9
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest