summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 10:02:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-13 10:29:28 +0100
commit5910231f4f92e29631bfc3c02c8ea40015b508a0 (patch)
tree869dc0d1696d0a793da922ed2a1a000170e68771 /dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
parentdev-python/typing-extensions: Bump to 4.1.0 (diff)
downloadgentoo-5910231f4f92e29631bfc3c02c8ea40015b508a0.tar.gz
gentoo-5910231f4f92e29631bfc3c02c8ea40015b508a0.tar.bz2
gentoo-5910231f4f92e29631bfc3c02c8ea40015b508a0.zip
dev-python/pytest-aiohttp: Bump to 1.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild')
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
new file mode 100644
index 000000000000..6f2f5b8373a9
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest