summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-09-24 10:28:30 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-09-24 10:28:30 -0500
commit38d15791e6e281ca813f53d7796199e88553db51 (patch)
tree55f94c099ce79672899e2fd1d58b159e4f850657 /dev-python/pytest-aiohttp
parentdev-python/multidict: remove version 2.0.0 (diff)
downloadgentoo-38d15791e6e281ca813f53d7796199e88553db51.tar.gz
gentoo-38d15791e6e281ca813f53d7796199e88553db51.tar.bz2
gentoo-38d15791e6e281ca813f53d7796199e88553db51.zip
dev-python/pytest-aiohttp: add version 0.1.3
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest1
-rw-r--r--dev-python/pytest-aiohttp/metadata.xml13
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
new file mode 100644
index 000000000000..0494d32a66d2
--- /dev/null
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -0,0 +1 @@
+DIST pytest-aiohttp-0.1.3.tar.gz 6192 SHA256 c2391c424b5342f9234f5f56f15183d167050b50c08c96258c1816cdb5a0283f SHA512 2271f7730b91812a619e04522c13b7e2ff76353179a4588226d0b943b67f7397b966c1d3c24016861cc3eda3a541b3f0d3b2858a6ca3586f7707e10581c34e4c WHIRLPOOL 8bf1608b655db5cc3a932316e48fbff6ab4045971e5e0d2e7240219798bcffdb2f130a8270163b67d8f213a15242127721b128b0edb2a97fa8e07f1ce2026d98
diff --git a/dev-python/pytest-aiohttp/metadata.xml b/dev-python/pytest-aiohttp/metadata.xml
new file mode 100644
index 000000000000..3e6df16d35d1
--- /dev/null
+++ b/dev-python/pytest-aiohttp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild
new file mode 100644
index 000000000000..1552cc1b806e
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-0.22.0[${PYTHON_USEDEP}]
+"