summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-02-26 16:14:12 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-02-26 18:02:05 +0000
commitf1d4afbf2f8f5ca5c5fdad4d7bd5bc29daea6840 (patch)
treea3cb8a27fed80c9a723ae50cc09a6311d0343d65 /dev-python/pytest-arraydiff
parentdev-python/glueviz: version bump (diff)
downloadgentoo-f1d4afbf2f8f5ca5c5fdad4d7bd5bc29daea6840.tar.gz
gentoo-f1d4afbf2f8f5ca5c5fdad4d7bd5bc29daea6840.tar.bz2
gentoo-f1d4afbf2f8f5ca5c5fdad4d7bd5bc29daea6840.zip
dev-python/pytest-arraydiff: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pytest-arraydiff')
-rw-r--r--dev-python/pytest-arraydiff/Manifest1
-rw-r--r--dev-python/pytest-arraydiff/metadata.xml15
-rw-r--r--dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild29
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-arraydiff/Manifest b/dev-python/pytest-arraydiff/Manifest
new file mode 100644
index 000000000000..043b48b51233
--- /dev/null
+++ b/dev-python/pytest-arraydiff/Manifest
@@ -0,0 +1 @@
+DIST pytest-arraydiff-0.1.tar.gz 8752 SHA256 4ca5aaa9a8dc55f0cf621ce6cca3060e320e32b1a500e2f87298ade0a5ece7e1 SHA512 321ea04ea7165753cb4d9aff3870d5297f78a0e5ddaf16aecd5dce622f061a2f664479bf8e3af1c7575e968fa66828ed2d0489473e7d8a236c07d1a31adfce5d WHIRLPOOL 08a7fdaa72717d7657ebaa97130aa34096aa0b3cc1ec5a1b507e103441e6991f22f732075416a51a8a34773619a75a3fcc451018f439d986eee5e9e8628c62ea
diff --git a/dev-python/pytest-arraydiff/metadata.xml b/dev-python/pytest-arraydiff/metadata.xml
new file mode 100644
index 000000000000..a5905e0e3a81
--- /dev/null
+++ b/dev-python/pytest-arraydiff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-arraydiff</remote-id>
+ <remote-id type="github">astrofrog/pytest-arraydiff</remote-id>
+ </upstream>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a plugin to faciliate image comparison for numpy arrays in Pytest.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild b/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
new file mode 100644
index 000000000000..6d12ab1feeb6
--- /dev/null
+++ b/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DOCS=( README.rst CHANGES.md )
+
+DESCRIPTION="pytest plugin to facilitate comparison of arrays"
+HOMEPAGE="https://github.com/astrofrog/pytest-arraydiff/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"