summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-09 09:40:52 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-09 12:49:41 +0100
commitb838d8b4627e1315910f23ef7be103a78f60ceaa (patch)
tree3fcf4f4f48f602ce7157b5d8789750fa0c6c0212 /dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild
parentdev-python/pytest-cache: Add tests (diff)
downloadgentoo-b838d8b4627e1315910f23ef7be103a78f60ceaa.tar.gz
gentoo-b838d8b4627e1315910f23ef7be103a78f60ceaa.tar.bz2
gentoo-b838d8b4627e1315910f23ef7be103a78f60ceaa.zip
dev-python/pytest-capturelog: Add tests
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild')
-rw-r--r--dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild b/dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild
index f42847a0b0a3..d6c626c9f734 100644
--- a/dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild
+++ b/dev-python/pytest-capturelog/pytest-capturelog-0.7.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1
@@ -15,6 +15,17 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
+IUSE="test"
RDEPEND="dev-python/py[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# Not included
+# https://bitbucket.org/memedough/pytest-capturelog/issues/5
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS=${PN/-/_} py.test -v -v test_capturelog.py || die
+}