summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-15 09:10:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-15 10:34:07 +0200
commit18aaf32871afdb84079276029f91a6604114fc75 (patch)
treef1612bf2e7ccee4cbc3cd2778d0de1e460fa05fc /dev-python/pytest-cov
parentdev-python/fsspec: Bump to 2021.05.0 (diff)
downloadgentoo-18aaf32871afdb84079276029f91a6604114fc75.tar.gz
gentoo-18aaf32871afdb84079276029f91a6604114fc75.tar.bz2
gentoo-18aaf32871afdb84079276029f91a6604114fc75.zip
dev-python/pytest-cov: Bump to 2.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.12.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 368a96d8db11..0d2d2dba61a0 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1 +1,2 @@
DIST pytest-cov-2.11.1.tar.gz 59143 BLAKE2B 21aeffbc9ccbe6a7c69a08fe3f0013204eb039c6dc9ddbb364a74ad10764e16ce7be0154e27beaab2c8f9b2a972131c4c2421c4aa4557efc18318556056a421b SHA512 19c465f5972ee0ee3b9a2f1a656fdf5457622cb449f73a6f707d377a617807dadda997a6875f0c081bc4c4f7039559c6e7ce820b818db42dfd053c016e1c3b4e
+DIST pytest-cov-2.12.0.tar.gz 59596 BLAKE2B 6eef2c062b687899009fdf7b4ef8825b3eeabc7be09fac897315cb99acb9176d11bf0d7f3704108caac1bddc32d158b88ddc69a5bd4815c1877cc238684abc3d SHA512 fc94abd8c38ff4015bad4f9f23ee4691f376d436c16f4951021afadfb94dd359a46924d3c7c43dc3193641943f88e0eab04429aa57d26a65bc95622e512639e1
diff --git a/dev-python/pytest-cov/pytest-cov-2.12.0.ebuild b/dev-python/pytest-cov/pytest-cov-2.12.0.ebuild
new file mode 100644
index 000000000000..8763efa3ffaa
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.12.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+# TODO: figure out how to make tests work without pytest-cov installed
+# first
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ ~dev-python/pytest-cov-${PV}[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme
+
+python_test() {
+ local deselect=(
+ # attempts to install packages via pip (network)
+ tests/test_pytest_cov.py::test_dist_missing_data
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}