summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 10:16:20 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 10:25:22 +0100
commit4477c3130e1b0d94f0d377dda8ca9701f052890f (patch)
treee1a55ab14929a1cb75307a7598ead761e99b34fe /dev-python/pytest-cov
parentdev-util/strace: whitespace (diff)
downloadgentoo-4477c3130e1b0d94f0d377dda8ca9701f052890f.tar.gz
gentoo-4477c3130e1b0d94f0d377dda8ca9701f052890f.tar.bz2
gentoo-4477c3130e1b0d94f0d377dda8ca9701f052890f.zip
dev-python/pytest-cov: Add missing test-dep on dev-python/fields
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild b/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..41e16e502292
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.python.org/pypi/pytest-cov"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
+ >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ )
+ =dev-python/pytest-xdist-1.15.0[${PYTHON_USEDEP}]
+ dev-python/pytest-capturelog[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_test() {
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
+ PYTEST_PLUGINS=${PN/-/_} \
+ py.test -v -v -x || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}