summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-04-12 09:46:58 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-04-12 09:46:58 -0400
commit4bdb9c403ad1461ba56dce08a9f2c1f1a3c2a580 (patch)
treec036039ba47bbe29789949fffa1e90f4d38a5d14 /dev-python/pytest-cov
parentdev-python/pytest-cov: bump to 2.6.1 (diff)
downloadgentoo-4bdb9c403ad1461ba56dce08a9f2c1f1a3c2a580.tar.gz
gentoo-4bdb9c403ad1461ba56dce08a9f2c1f1a3c2a580.tar.bz2
gentoo-4bdb9c403ad1461ba56dce08a9f2c1f1a3c2a580.zip
dev-python/pytest-cov: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild56
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.5.1-r2.ebuild56
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.5.1.ebuild55
4 files changed, 0 insertions, 168 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index d656767ad114..a6c3db6454a9 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,3 +1,2 @@
DIST pytest-cov-2.3.1.tar.gz 35378 BLAKE2B 758846db0b06ef9534823d3458ad6211b0cfc14b551a6e1737573a5c1c5bb59c23b26d3448ff8a67d65a4293ce75dd8c79d4916d3d9a7db5021db6b907152230 SHA512 79770beb53fbb43b5d68311c2efd0accbfd890ab6dad299da8c1c0b3d26b54d984807313b1507900cda7004bfb50fedc0bd4341cfcfce47849a4f24fc8184f11
-DIST pytest-cov-2.5.1.tar.gz 36201 BLAKE2B ba07d751c7635ee01262a6f2eeffb27393d58afadb625b220237ff9d014ecdda0f18c0b5fd7bdec66fa4a948f2bb70a715af6dc76664e9c573ad56520c8dee1e SHA512 868131d6ea6dd28deec6d653dec23ceb7d3adccfa2c6bcc0a3126bbb11e924e71f200676461b2202f274ce6e14d1799feb0917e3081817d9e8583271c18a43de
DIST pytest-cov-2.6.1.tar.gz 35307 BLAKE2B 11974ff70ed5609d7db3c4c35f5b528b0ec36b48cfaf06974a090127706e0964841347592ac3f1e086f46800857ee10c05404045b6a4b467ffa278c2ee1e1957 SHA512 2dfd16e013d8bfbe5d14990f419291b651dd11560328a7e59b5449016d51b17f84d4ee3866fda866c3530389d206b1c4c67c84b23f097281c3963ffd19ea8caa
diff --git a/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild b/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild
deleted file mode 100644
index 6683bf30f929..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
- >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- || (
- >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- )
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- use doc && sphinx-build -b html docs _build/html
-}
-
-python_test() {
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
- PYTEST_PLUGINS=${PN/-/_} \
- py.test -v -v -x || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( _build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pytest-cov/pytest-cov-2.5.1-r2.ebuild b/dev-python/pytest-cov/pytest-cov-2.5.1-r2.ebuild
deleted file mode 100644
index f82d830d8264..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.5.1-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
- >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- || (
- >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- )
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- use doc && sphinx-build -b html docs _build/html
-}
-
-python_test() {
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
- PYTEST_PLUGINS=${PN/-/_} \
- py.test -v -v -x || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( _build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pytest-cov/pytest-cov-2.5.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.5.1.ebuild
deleted file mode 100644
index 9b0b6785ecfd..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.5.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
- >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- || (
- >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- )
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- use doc && sphinx-build -b html docs _build/html
-}
-
-python_test() {
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
- PYTEST_PLUGINS=${PN/-/_} \
- py.test -v -v -x || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( _build/html/. )
- distutils-r1_python_install_all
-}