summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 09:53:41 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 09:57:50 +0100
commit8b4c640f2d417cea5edd6976f1947142db42897c (patch)
tree28fca936d5319bdc5645bdcde8c1ac2e8752a5c0 /dev-python/pytest-cov
parentdev-python/pkginfo: Remove old (diff)
downloadgentoo-8b4c640f2d417cea5edd6976f1947142db42897c.tar.gz
gentoo-8b4c640f2d417cea5edd6976f1947142db42897c.tar.bz2
gentoo-8b4c640f2d417cea5edd6976f1947142db42897c.zip
dev-python/pytest-cov: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.10.1.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 7328fa1a0dff..e12fb77fb050 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,3 +1,2 @@
-DIST pytest-cov-2.10.1.tar.gz 56822 BLAKE2B 45eba205a2c6687882445d3554cedc04ad556854f5eac8eb0fab7fda84cdf2736b034dfdceb664293d1add153a5271403eb94585a863676ccfef9ab09727d165 SHA512 2dd575141754a417f34b414ba7e07291c273abdc63a6b7dc72d317c6ec10076b83c2ad78eeefdda7cee1fd6f56932d838602da4dd760a1c0d12095be94c22568
DIST pytest-cov-2.11.0.tar.gz 59018 BLAKE2B f2ecaff439e701c3b7d029e4c51cb019d5222a083815ae5771341b0fa0f1b658f921a6eab75c0b568b630cc7ca75887f25ae7fb6fcaa9c2e8dc419397c4c799a SHA512 001f4975d7ad1a573354074366f983887ec9035bcc29afe9bd1ae2654fab520b8f479c5037936e6131749e5205077e937304e73d366cb43460db1f24a58b02be
DIST pytest-cov-2.11.1.tar.gz 59143 BLAKE2B 21aeffbc9ccbe6a7c69a08fe3f0013204eb039c6dc9ddbb364a74ad10764e16ce7be0154e27beaab2c8f9b2a972131c4c2421c4aa4557efc18318556056a421b SHA512 19c465f5972ee0ee3b9a2f1a656fdf5457622cb449f73a6f707d377a617807dadda997a6875f0c081bc4c4f7039559c6e7ce820b818db42dfd053c016e1c3b4e
diff --git a/dev-python/pytest-cov/pytest-cov-2.10.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.10.1.ebuild
deleted file mode 100644
index fc5c14c4dd9e..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.10.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-#PATCHES=(
-# # Bug 597708
-# "${FILESDIR}/${PN}-2.8.1-disable-broken-tests.patch"
-# "${FILESDIR}/${PN}-2.8.1-latest-setuptools.patch"
-# # https://github.com/pytest-dev/pytest-cov/issues/365
-# "${FILESDIR}/pytest-cov-2.8.1-python38.patch"
-#)
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-py3doc-enhanced-theme
-
-python_test() {
- distutils_install_for_testing
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib:${PYTHONPATH}" \
- PYTEST_PLUGINS=${PN/-/_} \
- pytest -vv || die "Tests failed under ${EPYTHON}"
-}