summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 23:05:44 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 23:06:06 +0200
commit8e7ec581565a9d59f8b72932442c7a90bfdbe5af (patch)
treeabd7d28abd2ea5ce2b2559194943141a11a7893e /dev-python/pytest-django/pytest-django-4.1.0.ebuild
parentdev-python/pillow: Bump to 8.0.1 (diff)
downloadgentoo-8e7ec581565a9d59f8b72932442c7a90bfdbe5af.tar.gz
gentoo-8e7ec581565a9d59f8b72932442c7a90bfdbe5af.tar.bz2
gentoo-8e7ec581565a9d59f8b72932442c7a90bfdbe5af.zip
dev-python/pytest-django: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-django/pytest-django-4.1.0.ebuild')
-rw-r--r--dev-python/pytest-django/pytest-django-4.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-django/pytest-django-4.1.0.ebuild b/dev-python/pytest-django/pytest-django-4.1.0.ebuild
new file mode 100644
index 000000000000..7e83c607671a
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.org
+ https://github.com/pytest-dev/pytest-django"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}