summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-11 09:14:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-11 12:46:50 +0200
commit4f7e574f9804dc83986f23aa0782ee8f0a5df3ae (patch)
treee4303beb46361091b76bd0c5c4448e4a57aecc87 /dev-python/pytest-django/pytest-django-4.2.0.ebuild
parentdev-python/hypothesis: Bump to 6.9.0 (diff)
downloadgentoo-4f7e574f9804dc83986f23aa0782ee8f0a5df3ae.tar.gz
gentoo-4f7e574f9804dc83986f23aa0782ee8f0a5df3ae.tar.bz2
gentoo-4f7e574f9804dc83986f23aa0782ee8f0a5df3ae.zip
dev-python/pytest-django: Bump to 4.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-django/pytest-django-4.2.0.ebuild')
-rw-r--r--dev-python/pytest-django/pytest-django-4.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-django/pytest-django-4.2.0.ebuild b/dev-python/pytest-django/pytest-django-4.2.0.ebuild
new file mode 100644
index 000000000000..ac4f7fbd41ae
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}