summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-26 15:39:00 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-26 17:13:36 -0800
commit60db45f9b08387d083b269044b34cef364096874 (patch)
tree18633f3dd9afb895b28a81d11ad805d6d5c7e438 /dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild
parentdev-python/u-msgpack: Version bump to 2.5.2, add py38 (diff)
downloadgentoo-60db45f9b08387d083b269044b34cef364096874.tar.gz
gentoo-60db45f9b08387d083b269044b34cef364096874.tar.bz2
gentoo-60db45f9b08387d083b269044b34cef364096874.zip
dev-python/pytest-expect: revbump, EAPI=7, py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild')
-rw-r--r--dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild b/dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..c94a4af4d0ac
--- /dev/null
+++ b/dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that stores test expectations by saving the set of failing tests"
+HOMEPAGE="https://github.com/gsnedders/pytest-expect/ https://pypi.org/project/pytest-expect/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/u-msgpack[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# no tests...
+RESTRICT="test"