summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-08 18:39:11 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-08 18:40:37 -0700
commit67ab3605c513e62f491eff431fcabfc1766b299f (patch)
tree4caacc5838987dc225b884364f9c2262e134f012 /dev-python/pytest-expect/pytest-expect-1.1.0.ebuild
parentx11-misc/xdg-utils: Bump to version 1.1.2 (diff)
downloadgentoo-67ab3605c513e62f491eff431fcabfc1766b299f.tar.gz
gentoo-67ab3605c513e62f491eff431fcabfc1766b299f.tar.bz2
gentoo-67ab3605c513e62f491eff431fcabfc1766b299f.zip
dev-python/pytest-expect: add package
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/pytest-expect/pytest-expect-1.1.0.ebuild')
-rw-r--r--dev-python/pytest-expect/pytest-expect-1.1.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pytest-expect/pytest-expect-1.1.0.ebuild b/dev-python/pytest-expect/pytest-expect-1.1.0.ebuild
new file mode 100644
index 000000000000..c547dff331ce
--- /dev/null
+++ b/dev-python/pytest-expect/pytest-expect-1.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that stores test expectations by saving the set of failing tests"
+HOMEPAGE="https://github.com/gsnedders/pytest-expect/ https://pypi.python.org/pypi/pytest-expect/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/u-msgpack[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"