summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-17 15:24:15 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-17 15:48:46 +0100
commit08f6bdac8b7b8c00bd92564fd51d2ee2a3b4a31a (patch)
treefa69fbab8e9c68067a40ef63d7b8d1ad1c06d0df /dev-python/pytest-httpbin
parentdev-python/httpbin: New package, ebuild written by me (diff)
downloadgentoo-08f6bdac8b7b8c00bd92564fd51d2ee2a3b4a31a.tar.gz
gentoo-08f6bdac8b7b8c00bd92564fd51d2ee2a3b4a31a.tar.bz2
gentoo-08f6bdac8b7b8c00bd92564fd51d2ee2a3b4a31a.zip
dev-python/pytest-httpbin: New package, ebuild written by me
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest1
-rw-r--r--dev-python/pytest-httpbin/metadata.xml12
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-0.2.0.ebuild38
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
new file mode 100644
index 000000000000..e18ea7ac48a6
--- /dev/null
+++ b/dev-python/pytest-httpbin/Manifest
@@ -0,0 +1 @@
+DIST pytest-httpbin-0.2.0.tar.gz 9372 SHA256 67a6d8e7890630b334e1cb38548a7118cb15930e218ece5b7a8bc94a8696ceed SHA512 a8e80979de59578a7cf16fa6cc08386bac9357bc8b48e34fc2a24cea18d531e61bf3c2474f8fc1b230dcd31641cb4bc960bab05e4bdbab98637c2fbf08671bfd WHIRLPOOL b5b532a1cc9e4b06f67787ca7ada0614b5145245934bcd796586fe0d18d186529388f608b24222a1b9372393e38f0a81df75ab205eafe134bb3287a34b122fec
diff --git a/dev-python/pytest-httpbin/metadata.xml b/dev-python/pytest-httpbin/metadata.xml
new file mode 100644
index 000000000000..3748c0ca3af8
--- /dev/null
+++ b/dev-python/pytest-httpbin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pytest-httpbin</remote-id>
+ <maintainer status="unknown">
+ <email>me@kevinmccarthy.org</email>
+ <name>Kevin McCarthy</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-0.2.0.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-0.2.0.ebuild
new file mode 100644
index 000000000000..12fb946bbfdf
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="https://github.com/kevin1024/pytest-httpbin http://pypi.python.org/pypi/pytest-httpbin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# Not includd
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS=pytest_httpbin \
+ py.test -v -s || die
+}