summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-15 03:39:29 +0000
committerSam James <sam@gentoo.org>2022-05-15 03:39:29 +0000
commit6e971615c701598e6c2fb842e5965a0c53f15e9a (patch)
tree76cbfeba9a98d5bec4bc9e61570e1a9c50c7897c /dev-python/pytest-localftpserver
parentprofiles: last rite dev-python/django-taggit-serializer (diff)
downloadgentoo-6e971615c701598e6c2fb842e5965a0c53f15e9a.tar.gz
gentoo-6e971615c701598e6c2fb842e5965a0c53f15e9a.tar.bz2
gentoo-6e971615c701598e6c2fb842e5965a0c53f15e9a.zip
dev-python/pytest-localftpserver: add 1.1.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-localftpserver')
-rw-r--r--dev-python/pytest-localftpserver/Manifest1
-rw-r--r--dev-python/pytest-localftpserver/pytest-localftpserver-1.1.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-localftpserver/Manifest b/dev-python/pytest-localftpserver/Manifest
index 0bff5dd82d10..6ca729245df6 100644
--- a/dev-python/pytest-localftpserver/Manifest
+++ b/dev-python/pytest-localftpserver/Manifest
@@ -1 +1,2 @@
DIST pytest_localftpserver-1.1.2.tar.gz 41275 BLAKE2B ddab430541208ea7e30b7091f0e5ed1ff347c4f289c79e1bf93e7fc56ac3d9076065afefb383e8e394cf702ce906747c7450acc0423df73cba5762cac01efec2 SHA512 44dfb4e680f82d6156212a06e320d437c5aa947b149177bb05a612473f882e0d2e8ff02751d0f79d56596cada82a299c9266b5849220687cea1028df7ca1bb00
+DIST pytest_localftpserver-1.1.3.tar.gz 44510 BLAKE2B 98085adc5dd31bb6556ea1f31c6342e8453a07c24658baf5fe94e91a001e9b88c5f6ef01a3a8419bd7b1bd3eb053ef52788c80926c5984b523d9f575224ff6ec SHA512 8058f7c6853acf709fdf4e0ce169af4281e2236a615261c0e148965dc1899af78b558ae5231600a106c538c1790ad886bea80ba7ebf278c70b6d553e58c0202b
diff --git a/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.3.ebuild b/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.3.ebuild
new file mode 100644
index 000000000000..e826b9bbbf46
--- /dev/null
+++ b/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A PyTest plugin which provides an FTP fixture for your tests"
+HOMEPAGE="https://pypi.org/project/pytest-localserver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/pyftpdlib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+EPYTEST_IGNORE=(
+ # These tests require python wget module, but not in Portage
+ tests/test_pytest_localftpserver.py
+ tests/test_pytest_localftpserver_TLS.py
+ tests/test_pytest_localftpserver_with_env_var.py
+)
+
+distutils_enable_tests pytest