summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-26 10:49:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-26 12:16:59 +0200
commit5bd7ceb1f1148c5be68b67bf408b9cb694de6c49 (patch)
tree045fcaf273b553117257351ae35f7acd00b9c241 /dev-python/pytest-localserver/pytest-localserver-0.5.0-r1.ebuild
parentdev-python/jsonref: Enable py3.8 (diff)
downloadgentoo-5bd7ceb1f1148c5be68b67bf408b9cb694de6c49.tar.gz
gentoo-5bd7ceb1f1148c5be68b67bf408b9cb694de6c49.tar.bz2
gentoo-5bd7ceb1f1148c5be68b67bf408b9cb694de6c49.zip
dev-python/pytest-localserver: Provide a pure py3 revision
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-localserver/pytest-localserver-0.5.0-r1.ebuild')
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.5.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.5.0-r1.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..bdee1047cae3
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.5.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Py.test plugin to test server connections locally"
+HOMEPAGE="https://pypi.org/project/pytest-localserver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+
+RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest