summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-22 10:18:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-22 10:18:12 +0300
commit8034ddfe19a8668dcd1fe00f94f5f7d0679ab05a (patch)
tree4247fcf04d64fc7b1031f29c026c14eabd7c1b00 /dev-python/pytest-mock
parentdev-python/geventhttpclient: fix dep to dev-python/gevent[events(+)] (diff)
downloadgentoo-8034ddfe19a8668dcd1fe00f94f5f7d0679ab05a.tar.gz
gentoo-8034ddfe19a8668dcd1fe00f94f5f7d0679ab05a.tar.bz2
gentoo-8034ddfe19a8668dcd1fe00f94f5f7d0679ab05a.zip
dev-python/pytest-mock: fix running with pytest-xprocess installed
Closes: https://bugs.gentoo.org/813061 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.6.1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-3.6.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.6.1.ebuild
index 8f048a9f8998..3125f886d4a5 100644
--- a/dev-python/pytest-mock/pytest-mock-3.6.1.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.6.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
@@ -19,14 +19,18 @@ BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
+src_prepare() {
+ sed -e 's/runpytest_subprocess(/&"-p","no:xprocess",/' -i tests/test_pytest_mock.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
- local deselect=()
if has_version dev-python/mock; then
- deselect+=(
+ local EPYTEST_DESELECT=(
tests/test_pytest_mock.py::test_standalone_mock
)
fi
distutils_install_for_testing
- epytest --assert=plain ${deselect[@]/#/--deselect }
+ epytest --assert=plain
}