summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-20 14:51:48 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-20 15:40:54 +0200
commit4082d8ba710a563e772278eda7d577b0d97337f9 (patch)
tree3a21c741227c00308484eea05fdf1cd319e685ad /dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
parentdev-python/pylint: Add missing RDEP on backports-functools-lru-cache (diff)
downloadgentoo-4082d8ba710a563e772278eda7d577b0d97337f9.tar.gz
gentoo-4082d8ba710a563e772278eda7d577b0d97337f9.tar.bz2
gentoo-4082d8ba710a563e772278eda7d577b0d97337f9.zip
dev-python/pytest-pylint: Add pkg needed for aiohttp-cors tests
Diffstat (limited to 'dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild')
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
new file mode 100644
index 000000000000..d8c094245298
--- /dev/null
+++ b/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check source code with pylint"
+HOMEPAGE="https://github.com/carsongee/pytest-pylint"
+SRC_URI="https://github.com/carsongee/pytest-pylint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # pytest grabs the options from tox.ini automatically
+ # but setup.py does not declare pytest-pep8 as a dep,
+ # so it's missing from env created by distutils_install_for_testing
+ sed -i -e 's:--pep8::' tox.ini || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}