summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-14 00:56:28 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-10-14 01:09:03 +0200
commit7becf523604f65f212d790e2f614698cc4f943f0 (patch)
tree830969e1a8dd26b5c82535e6d4beb96170adf9de /dev-python/pytest-pylint
parentsys-kernel/raspberrypi-image: cleanup redundant version (diff)
downloadgentoo-7becf523604f65f212d790e2f614698cc4f943f0.tar.gz
gentoo-7becf523604f65f212d790e2f614698cc4f943f0.tar.bz2
gentoo-7becf523604f65f212d790e2f614698cc4f943f0.zip
dev-python/pytest-pylint: bump to 0.17.0, add Python 3.8 support
Also remove pytest-runner requirement. Closes: https://bugs.gentoo.org/746422 Closes: https://bugs.gentoo.org/705078 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pytest-pylint')
-rw-r--r--dev-python/pytest-pylint/Manifest1
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-pylint/Manifest b/dev-python/pytest-pylint/Manifest
index 0c5391f7428a..9160ce15a41e 100644
--- a/dev-python/pytest-pylint/Manifest
+++ b/dev-python/pytest-pylint/Manifest
@@ -1 +1,2 @@
DIST pytest-pylint-0.14.1.tar.gz 8144 BLAKE2B d78892e3e606ec588b48a252db447e1cc76e27e45606670da3a3acddf040485004a7af84474732b044fdbf80ad760c07fda5e35030b9b2c9e5ce89f4809529c2 SHA512 697cd40e8e4c3722e382c7fd2dbebcb1728675e35b60396628576ec09735595af56431a2c080f29a2f35f304d912c80e4afdf0f8bd21a3adeae3156b9e58c751
+DIST pytest-pylint-0.17.0.tar.gz 11660 BLAKE2B b536dcaaf0ac652dcbe66018fa22e120782496de58f74003c523eb003ff0556f9b738e528a85724a1e589e18bb0024d99fbeb581b7f5b36ec349ad07da8d26d0 SHA512 a23937ec191ef14829530ac6bf31b882bc250f312e2ba6e3b8cc1187c888511e4b67ffaf5bce176556a621fbf80239b30c43c635898d458bb8d819e92a9f8142
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild
new file mode 100644
index 000000000000..fd41ba8504b1
--- /dev/null
+++ b/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check source code with pylint"
+HOMEPAGE="https://github.com/carsongee/pytest-pylint"
+# Tests should be included in PyPI tarballs by the next release:
+# https://github.com/carsongee/pytest-pylint/commit/4e7f06701ca06697a22a029db9857fa2fdf7c033
+SRC_URI="https://github.com/carsongee/pytest-pylint/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pylint-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable flake8 and pep8 options
+ sed -i -e '/^addopts =/d' tox.ini || die
+ # Remove pytest-runner requirement
+ sed -i -e "s/'pytest-runner'//" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Required to load the pytest-pylint plugin
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}