summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-11 14:20:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-16 20:20:58 +0200
commita26430a114f694f1f53c9893582f6773eee34eb2 (patch)
treee5fc8aa8ac86fb877f205e2f8ea33082be87ec16 /dev-python/pytest-pylint
parentdev-python/cython: correct DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-a26430a114f694f1f53c9893582f6773eee34eb2.tar.gz
gentoo-a26430a114f694f1f53c9893582f6773eee34eb2.tar.bz2
gentoo-a26430a114f694f1f53c9893582f6773eee34eb2.zip
dev-python/pytest-pylint: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/736114 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-pylint')
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild
index 85605fa7eb8b..b8546e9fb732 100644
--- a/dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild
+++ b/dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -20,7 +21,6 @@ RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pylint[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/pytest-pep8[${PYTHON_USEDEP}]
)"