summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-16 17:05:34 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-16 17:05:34 -0500
commitc81a3b67d247329e3e725e5c7a46b78492fe4600 (patch)
treec10744ac5e4cc3220558b46cb1524ca4733dd0d1 /dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild
parentnet-misc/curl: add support for brotli (diff)
downloadgentoo-c81a3b67d247329e3e725e5c7a46b78492fe4600.tar.gz
gentoo-c81a3b67d247329e3e725e5c7a46b78492fe4600.tar.bz2
gentoo-c81a3b67d247329e3e725e5c7a46b78492fe4600.zip
dev-python/pytest-qt: also use dep on PyQt[testlib], bug #644816
Closes: https://bugs.gentoo.org/644816 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild')
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild
new file mode 100644
index 000000000000..317a66593a46
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for PyQt4 or PyQt5 applications"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-qt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytest-2.7.0[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,testlib,${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Test make assumptions about Qt environment
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}