summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-01 12:54:13 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-01 12:54:31 -0500
commit5b3021c530118874cc1bd62e6259f8356e2d0239 (patch)
treedbe1c34fe647d2a5a923056d598ae6d056ec2318 /dev-python/pytest-qt
parentprofiles: remove last-rited packages (diff)
downloadgentoo-5b3021c530118874cc1bd62e6259f8356e2d0239.tar.gz
gentoo-5b3021c530118874cc1bd62e6259f8356e2d0239.tar.bz2
gentoo-5b3021c530118874cc1bd62e6259f8356e2d0239.zip
dev-python/pytest-qt: initial commit
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest1
-rw-r--r--dev-python/pytest-qt/metadata.xml13
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0.ebuild47
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
new file mode 100644
index 000000000000..da123ced3b7c
--- /dev/null
+++ b/dev-python/pytest-qt/Manifest
@@ -0,0 +1 @@
+DIST pytest-qt-2.3.0.tar.gz 106707 BLAKE2B cf02aed42481cbcadfaaa15c883f3055337f6f32e33b7dfbce986ecd9936218ee5bfe9f21e1a910aa970e7adf88dd24415d63f40655e8417863e96a4285fd466 SHA512 2bda4b5f60ba68b151ce62972661cd704e40f4cadaef2583882099e96100b5c5b9398de796e851579e026e9736e07539c4db8c10eef16929ce729c4dd7a22940
diff --git a/dev-python/pytest-qt/metadata.xml b/dev-python/pytest-qt/metadata.xml
new file mode 100644
index 000000000000..b90dc9952a18
--- /dev/null
+++ b/dev-python/pytest-qt/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-cov</remote-id>
+ <remote-id type="bitbucket">memedough/pytest-cov</remote-id>
+ <remote-id type="github">pytest-dev/pytest-cov</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
new file mode 100644
index 000000000000..c78a8782aac4
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for PyQt4 or PyQt5 applications"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-qt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytest-2.7.0[${PYTHON_USEDEP}]
+ || (
+ dev-python/PyQt4
+ dev-python/PyQt5
+ )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_test() {
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
+ PYTEST_PLUGINS=${PN/-/_} \
+ py.test -v -v -x || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}