summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-21 01:46:30 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-21 02:12:59 +0100
commitd8eb375382005d24fd19828df162b1dbdce50e25 (patch)
tree335c85ff775425511ed5ea791bf4a5108ee8d190 /dev-python/pytest-runner/pytest-runner-2.10.1.ebuild
parentPartially revert "profiles/arch/ia64: Clean obsolete package.use* entries" (diff)
downloadgentoo-d8eb375382005d24fd19828df162b1dbdce50e25.tar.gz
gentoo-d8eb375382005d24fd19828df162b1dbdce50e25.tar.bz2
gentoo-d8eb375382005d24fd19828df162b1dbdce50e25.zip
dev-python/pytest-runner: Version bump to 2.10.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pytest-runner/pytest-runner-2.10.1.ebuild')
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.10.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-runner/pytest-runner-2.10.1.ebuild b/dev-python/pytest-runner/pytest-runner-2.10.1.ebuild
new file mode 100644
index 000000000000..fd54c1cfd246
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-2.10.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests during installation of setup.py files"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-runner https://bitbucket.org/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ "
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+# Test not included
+RESTRICT="test"
+
+python_compile_all() {
+ # The build by rst2html.py makes non fatal errors building index.rst
+ if use doc; then
+ rst2html.py docs/history.rst > docs/history.html
+ rst2html.py docs/index.rst > docs/index.html
+ HTML_DOCS=( docs/*.html )
+ fi
+}
+
+python_test() {
+ esetup.py pytest
+}