summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-11-05 13:46:47 +0100
committerJustin Lecher <jlec@gentoo.org>2016-11-05 13:46:47 +0100
commit50d83dc86cdbea175ed32c54085cf74b890d88cf (patch)
tree5e27b1b661645f3052bd9165f9b899990ab4b585 /dev-python/pytest-runner/pytest-runner-2.9.ebuild
parentdev-python/pytables: Add back included sources (diff)
downloadgentoo-50d83dc86cdbea175ed32c54085cf74b890d88cf.tar.gz
gentoo-50d83dc86cdbea175ed32c54085cf74b890d88cf.tar.bz2
gentoo-50d83dc86cdbea175ed32c54085cf74b890d88cf.zip
dev-python/pytest-runner: Version Bump
Drop pypy3 support as pytest dropped it Package-Manager: portage-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytest-runner/pytest-runner-2.9.ebuild')
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.9.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-runner/pytest-runner-2.9.ebuild b/dev-python/pytest-runner/pytest-runner-2.9.ebuild
new file mode 100644
index 000000000000..0819783bdb63
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-2.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests during installation of setup.py files"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-runner https://bitbucket.org/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ "
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+# Test not included
+RESTRICT="test"
+
+python_compile_all() {
+ # The build by rst2html.py makes non fatal errors building index.rst
+ if use doc; then
+ rst2html.py docs/history.rst > docs/history.html
+ rst2html.py docs/index.rst > docs/index.html
+ fi
+}
+
+python_test() {
+ esetup.py pytest
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}