summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 17:11:41 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 17:22:19 -0700
commit19bab308d8ef076e4005afdcfd8ee76060445d82 (patch)
tree24ff6c1918eeaa9ceca12030d8e05226280362a8 /dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild
parentapp-arch/rpm2targz: drop old (diff)
downloadgentoo-19bab308d8ef076e4005afdcfd8ee76060445d82.tar.gz
gentoo-19bab308d8ef076e4005afdcfd8ee76060445d82.tar.bz2
gentoo-19bab308d8ef076e4005afdcfd8ee76060445d82.zip
dev-python/pytest-salt-2020.1.27: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild')
-rw-r--r--dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild b/dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild
new file mode 100644
index 000000000000..30088fddf779
--- /dev/null
+++ b/dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+DESCRIPTION="PyTest Salt Plugin"
+HOMEPAGE="https://github.com/saltstack/pytest-salt"
+SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/psutil-4.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+"
+#BDEPEND="
+# test? ( app-admin/salt[${PYTHON_USEDEP}] )
+#"
+
+# tests need network access
+RESTRICT="test"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}