summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 08:38:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 08:55:21 +0200
commitca92661211c88098588da6034366db8c7b20e8df (patch)
tree1494111e76477da752298e7b5fed2ca03c735905 /dev-python/pytest-subtesthack
parentsys-kernel/vanilla-sources: Automated version bump to 5.18.0 (diff)
downloadgentoo-ca92661211c88098588da6034366db8c7b20e8df.tar.gz
gentoo-ca92661211c88098588da6034366db8c7b20e8df.tar.bz2
gentoo-ca92661211c88098588da6034366db8c7b20e8df.zip
dev-python/pytest-subtesthack: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r2.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..665164757961
--- /dev/null
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
+HOMEPAGE="
+ https://github.com/untitaker/pytest-subtesthack/
+ https://pypi.org/project/pytest-subtesthack/
+"
+SRC_URI="
+ https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest