summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-20 18:45:18 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-21 18:13:20 -0700
commita0aca02da19c5f134abc71ec6aa284a41c9b090e (patch)
tree5580f29905a490e075ab7c0049f749ae4ae24df9 /dev-python/pytest-tempdir
parentdev-python/pytest-helpers-namespace-2019.1.8-r1: revbump, add py38, tests (diff)
downloadgentoo-a0aca02da19c5f134abc71ec6aa284a41c9b090e.tar.gz
gentoo-a0aca02da19c5f134abc71ec6aa284a41c9b090e.tar.bz2
gentoo-a0aca02da19c5f134abc71ec6aa284a41c9b090e.zip
dev-python/pytest-tempdir: new package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-tempdir')
-rw-r--r--dev-python/pytest-tempdir/Manifest1
-rw-r--r--dev-python/pytest-tempdir/metadata.xml8
-rw-r--r--dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-tempdir/Manifest b/dev-python/pytest-tempdir/Manifest
new file mode 100644
index 000000000000..9594d221c021
--- /dev/null
+++ b/dev-python/pytest-tempdir/Manifest
@@ -0,0 +1 @@
+DIST pytest-tempdir-2019.10.12.tar.gz 9859 BLAKE2B fe4d32d2de3d577952b90a811c38f1cfa0c16badf9115a1b70faf07f0123e29935c01bfc3c1b9c616a0eeb3e0da9f42a4415687a4862830e0edea505a99dfc04 SHA512 d6f8994423d9be90f4be20878f980ad4604475ccd4b65975cd3cad357c2d6a2a7bb8623e4ccd7441437ad72b7899d8b59ae19ca3a52c35a6c24456e44b7626de
diff --git a/dev-python/pytest-tempdir/metadata.xml b/dev-python/pytest-tempdir/metadata.xml
new file mode 100644
index 000000000000..56cae167d372
--- /dev/null
+++ b/dev-python/pytest-tempdir/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild b/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild
new file mode 100644
index 000000000000..aa804018536a
--- /dev/null
+++ b/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin to support for a predictable and repeatable temporary directory"
+HOMEPAGE="https://github.com/saltstack/pytest-tempdir"
+SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}