summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-12 19:02:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-12 19:34:03 +0200
commit9d55e375f39a853b890e1bc8a2cb2921b4228a92 (patch)
tree4b0abbc8fe12aead6c71f262ce4b32bb8809fd55 /dev-python/pytest-testinfra
parentdev-python/python-lsp-black: Bump to 1.2.1 (diff)
downloadgentoo-9d55e375f39a853b890e1bc8a2cb2921b4228a92.tar.gz
gentoo-9d55e375f39a853b890e1bc8a2cb2921b4228a92.tar.bz2
gentoo-9d55e375f39a853b890e1bc8a2cb2921b4228a92.zip
dev-python/pytest-testinfra: Bump to 6.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest1
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.7.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index a4654b7565e3..d0bea5315dd0 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1 +1,2 @@
DIST pytest-testinfra-6.6.0.tar.gz 78285 BLAKE2B c7583685aeb770f76e4679730599909b8fff53d1909664f55e2d35f7f5a6a96741e3aa56b81da464c2d474d1d5f646892e36a4f9b6938327cb526476536b0b6c SHA512 f78f1cd5240e157d4e2949178f29900a7b85a6065b4113b18273af3f1fef6b19c859192f59426b93eba48418bb89d163ad1d951e97d4fdfcea4394635a05140a
+DIST pytest-testinfra-6.7.0.tar.gz 79187 BLAKE2B 08678f381392fe8a1fe335adc90ac6dc67c5bfa33c87f4e9d81b439eaabd29c393b8dc80cc79625784e76e5b0e264cdfc272cddb531acefbac9a8327be46f7be SHA512 d11f30da0eae9f215173d3f84e6ba7965d926b8ef6c49619c2ccae3d3ff215f351b950eea019e6516a56de0aa7bc533658af978d827a3ad3d1c50e37902b6f91
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.7.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.7.0.ebuild
new file mode 100644
index 000000000000..90b45ea64fde
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-testinfra/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# Ansible is called via its CLI
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ <app-admin/ansible-5
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ app-admin/salt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}