summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 21:49:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 22:37:35 +0200
commit662d14577395b7d3302eda1df7d918d293abb09f (patch)
tree30734a0719ce23166866c0c85b1da12c78e6a256 /dev-python/pytest-timeout
parentdev-python/pytest-forked: Enable py3.11 (diff)
downloadgentoo-662d14577395b7d3302eda1df7d918d293abb09f.tar.gz
gentoo-662d14577395b7d3302eda1df7d918d293abb09f.tar.bz2
gentoo-662d14577395b7d3302eda1df7d918d293abb09f.zip
dev-python/pytest-timeout: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.1.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.1.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.1.0.ebuild
index 133c5efa0b91..854117081a47 100644
--- a/dev-python/pytest-timeout/pytest-timeout-2.1.0.ebuild
+++ b/dev-python/pytest-timeout/pytest-timeout-2.1.0.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="pytest plugin to abort hanging tests"
@@ -21,7 +22,9 @@ BDEPEND="
test? (
dev-python/pexpect[${PYTHON_USEDEP}]
!hppa? (
- dev-python/pytest-cov[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ ' python3_{8..10} pypy3)
)
)"