summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-08 17:19:18 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-08 17:33:42 -0400
commit2d611da6e902d731629439c8be81fd494ff795ca (patch)
tree6305efd08fa71addcccb5133e8b83493d93269a6 /dev-python/pytest-xdist/pytest-xdist-1.23.2.ebuild
parentapp-emulation/simplevirt: initial snapshot import (diff)
downloadgentoo-2d611da6e902d731629439c8be81fd494ff795ca.tar.gz
gentoo-2d611da6e902d731629439c8be81fd494ff795ca.tar.bz2
gentoo-2d611da6e902d731629439c8be81fd494ff795ca.zip
dev-python/pytest-xdist: bump to 1.23.2
I dropped the pytest >= 3.4 constraint because it was a mistake done upstream. This mistake has been fixed in v1.22.5. Removing pytest version constraint will greatly facilitate stabilization... Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-1.23.2.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.23.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.23.2.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.23.2.ebuild
new file mode 100644
index 000000000000..3a33e3ed4256
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.23.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/execnet-1.1[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv testing || die "Tests failed under ${EPYTHON}"
+}