summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-10 00:43:09 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-10 09:06:30 +0100
commit059f436f9c8be87489fb7c87c6ac622d69b0a2c7 (patch)
tree117c5fe0e274a74d866af7aee0ac9727f09ef7de /dev-python/pytest-xdist
parentdev-ruby/font-awesome-rails: add 4.7.0.7 (diff)
downloadgentoo-059f436f9c8be87489fb7c87c6ac622d69b0a2c7.tar.gz
gentoo-059f436f9c8be87489fb7c87c6ac622d69b0a2c7.tar.bz2
gentoo-059f436f9c8be87489fb7c87c6ac622d69b0a2c7.zip
dev-python/pytest-xdist: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.2.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 261ee16f3709..aed96c0d4de3 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,2 +1,3 @@
DIST pytest-xdist-1.34.0.tar.gz 66151 BLAKE2B ac5274e32b3ef6b72113efd4300eb6946a977e0e202d3383abcdbc022126b7806edb326ddc16abb1219e22eb091e06a9c39fce3031aaf5943d4ad653a47af142 SHA512 69e9877ee0268d71d7c0ca202ccc46b3ba1a9271f0e6e4ac4b76602833f9b7012364eb6924ae994e76c1d48d63adf1702d4c5e6ed5b75c52ac7ebae958210e24
DIST pytest-xdist-2.2.0.tar.gz 64781 BLAKE2B 17287c28f31c42c6a8fe3622d4ba920a530e0ced3bc99cffd8f9de91c3498cc2a3b654cc32bd5b09ee8ec6c1f64226aec736acafd73397be2eb34bd3d192bb46 SHA512 2027f8512fbd6cb68ab36eb774b9d8b7e855c181733b884f394d0e84994926b4fe6158dbd55808328b262497036f101e71cb86553340eba0031d654f34541689
+DIST pytest-xdist-2.2.1.tar.gz 64956 BLAKE2B 7ea18b0e7893000ed9d8718506a7b0f7cf45444196a23e3defec34639c2159b52c7a533ddbc0e0a9b3c3f1e0a867ad5c85e3549167e9b7049ce718646ed50717 SHA512 0732f5ffb56eead3d1aeecd37381c2d9c6ed22398e8e51e9358b562765d737ebde48ecb6fe9f90d9a46902dba1422721cb2c7bfc9fc13918aa2c3b8e6a5e48c4
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.2.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.2.1.ebuild
new file mode 100644
index 000000000000..d27d1d1c78ab
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# pytest-xdist >= 2 fails with pytest < 6
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-services-conflict.patch
+)
+
+distutils_enable_tests --install pytest