summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-17 08:03:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-17 08:39:59 +0200
commit58ae57d08931ff6ffd5ac130661340fc76cc1636 (patch)
tree61fde769b1055e50889706393149e9c4bff79940 /dev-python/pytest-xdist
parentdev-python/psycopg: Bump to 2.9.1 (diff)
downloadgentoo-58ae57d08931ff6ffd5ac130661340fc76cc1636.tar.gz
gentoo-58ae57d08931ff6ffd5ac130661340fc76cc1636.tar.bz2
gentoo-58ae57d08931ff6ffd5ac130661340fc76cc1636.zip
dev-python/pytest-xdist: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 4008b8ef3773..ac8abbc0ef25 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1 +1,2 @@
DIST pytest-xdist-2.2.1.tar.gz 64956 BLAKE2B 7ea18b0e7893000ed9d8718506a7b0f7cf45444196a23e3defec34639c2159b52c7a533ddbc0e0a9b3c3f1e0a867ad5c85e3549167e9b7049ce718646ed50717 SHA512 0732f5ffb56eead3d1aeecd37381c2d9c6ed22398e8e51e9358b562765d737ebde48ecb6fe9f90d9a46902dba1422721cb2c7bfc9fc13918aa2c3b8e6a5e48c4
+DIST pytest-xdist-2.3.0.tar.gz 66072 BLAKE2B 367ff15cd46b8594668ccd9710a2fc7665295d41e268b464b81d5e740a580d70621a1ab5ab590788e44887b7aa3049a83853ea097c0cff54e22c3422c8f11b24 SHA512 bf49a1684b29f0ae21621b9d293f530cf2fa3d88b33f631fb803aef872c0d5ef6b3bbf2e16d01be8a6c1872fe3e6cff86ab842e3000b9e642fb46c2a170627f6
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
new file mode 100644
index 000000000000..127050a2150e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# pytest-xdist >= 2 fails with pytest < 6
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-services-conflict.patch
+)
+
+distutils_enable_tests --install pytest