summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-21 23:30:23 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-21 23:40:35 -0400
commit99fc2c71df965c82f15953abb0da3e5fe5b18cac (patch)
treefcb0be7e5dcf8f97a55935efce8cb29ed0821e29 /dev-python/pytest-xdist
parentdev-python/pytest-forked: initial import for newer pytest-xdist (diff)
downloadgentoo-99fc2c71df965c82f15953abb0da3e5fe5b18cac.tar.gz
gentoo-99fc2c71df965c82f15953abb0da3e5fe5b18cac.tar.bz2
gentoo-99fc2c71df965c82f15953abb0da3e5fe5b18cac.zip
dev-python/pytest-xdist: version bump to 1.20.0
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.20.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 17b315a344f0..1a4d0d163596 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,2 +1,3 @@
DIST pytest-xdist-1.14.zip 106585 SHA256 4a5e1199122fa29e3017d8d189f59ccc5d82e841474ba2a1eec0e89606153623 SHA512 4cafae77736da6880e8dd42aaa91f68bbc959ff7dabcd231018b144b54f96ccf1b11abb09474e260876bbdf731053005fdbd348ac87461f303d8f8f7af643e36 WHIRLPOOL 7d1f57a6d5cbf08661254f3f47d72c3cfbe931f14985c4b24abb627bd10fdc3f2fa21d05085766c0ed425e74713f991b53bdde957bd64ea4f64a206c2f4feffc
DIST pytest-xdist-1.15.0.tar.gz 87799 SHA256 6238395f8bd050f9288a3b10f34330edece80f4424cf2b4204d6e7d622f0f00b SHA512 6429bd0c85024a2dcb453e4264f06d4a548637c4dcdeabf73d2b78a112ace70ff61cf0849a4845cc70a7650d10a99e5fe1087d3b7dba4b941ec0a771fc9338ed WHIRLPOOL 0454f615c24b14a86aba58c7bc9dbc2b43af82551ae3912358603450f0e3ac94e849eb2fc57bdda8bd1de5201111a3986d2c12c9f2923f4296718ffee84d661b
+DIST pytest-xdist-1.20.0.tar.gz 56578 SHA256 7924d45c2430191fe3679a58116c74ceea13307d7822c169d65fd59a24b3a4fe SHA512 e91fa6fa2f3130d38d674f62e6332581b88b43d7a63562701edf705de1b8a633b6b2011a6fa5fcece955181f6cf263a8ca7481c5e5f9f1d56ce198327f7dd30a WHIRLPOOL 0a2311d92f372c692c579350792d7051c4dfa046bc22a6eeeeb9b214982f90c12b28f7c0875fec591741bf82a3e6feac2b807a9ccde5c920b14a8b9865d58e3a
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.20.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.20.0.ebuild
new file mode 100644
index 000000000000..7e6d21d54712
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.20.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-xdist https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/execnet-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ distutils_install_for_testing
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+}