summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-20 18:11:26 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-20 21:10:41 +0100
commit9dd8f4e789c44cc4748cbebad310987caf0b8e91 (patch)
treeea0f4e0689cbf317b6c672224ec096c8c291a09a /dev-python/pytest-xdist
parentdev-python/trustme: Bump to 0.6.0 (diff)
downloadgentoo-9dd8f4e789c44cc4748cbebad310987caf0b8e91.tar.gz
gentoo-9dd8f4e789c44cc4748cbebad310987caf0b8e91.tar.bz2
gentoo-9dd8f4e789c44cc4748cbebad310987caf0b8e91.zip
dev-python/pytest-xdist: Bump to 1.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.31.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 014c6775b2b5..98896ef5ab86 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,3 +1,4 @@
DIST pytest-xdist-1.23.2.tar.gz 59932 BLAKE2B f2cf73914cf095217fb8b472f5e5f7918435c75f8da1694cc7ceb920ac3a7390d84bea93cca558ba26cf3d14a01815374eab9ea03a137a8a9f5dba2f2d4453a8 SHA512 4aae9a6d74e53a29630d0233d0a903d008023e322de726ef7ab7cf4865f428942f96cc65264e19726cb6213264edaa747da2cb6f368989417ba821f2a3f9b654
DIST pytest-xdist-1.28.0.tar.gz 61486 BLAKE2B ef8157079ea890342cd566f327588148fa898a3404e3edcffb60ba8ba37d9473b4c2a47fc737f7bb074042c6aadd737ac51f348ce79a718eb446036016cd5e23 SHA512 89b8885103a944ae72535de40028db052f76631ade6f969489d3dc3a1a61a3233df6655d0905d9f5253f23740a15aea824b460c680e79c16f275b31cb2abd6ad
DIST pytest-xdist-1.30.0.tar.gz 62286 BLAKE2B 8d6a79c123bcee81751f2dd3a87e1d8effc82ff48a701c8cf0014292e5df575136d25847794c8e9fc94eb88a37cb42c659a142212faf30b0d1a0b1f9f948d2d6 SHA512 978b67df2366d916db62af21f2c610ac5d2de43cecf3260ec9bf52f904098514c3052ce8ca2195c17addd4012f3c5d38ce8a701d26c8158142a821b0d0cf9122
+DIST pytest-xdist-1.31.0.tar.gz 66133 BLAKE2B 79fe5f3bcad3421c1c751ffe6e09f0da42d4ff7c0016cb421ffabcab167028ec41ccfb02bbb275564cd74b13ade8d6e79bbb70b34995f3bc9000604a1533df9a SHA512 b7960d20295232b251c8ddcc5a3b9d6e7b761d577ba11c2647b4b4b410ee5c05998cf57fa57208561eb3ea7c4914db1fd446173794589d8c8e8e79ff8e0ad3aa
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.31.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.31.0.ebuild
new file mode 100644
index 000000000000..75de4e5bfc87
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.31.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.4[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv testing || die "Tests failed under ${EPYTHON}"
+}