summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-25 13:40:21 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-25 13:41:02 -0400
commita6303c9426a1ea3745b0e059b5d1f0a0703899ce (patch)
treed50dcbcdc6f92967518008e39c7ce246ac621ab8 /dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
parentdev-util/lttng-modules: Version bump (diff)
downloadgentoo-a6303c9426a1ea3745b0e059b5d1f0a0703899ce.tar.gz
gentoo-a6303c9426a1ea3745b0e059b5d1f0a0703899ce.tar.bz2
gentoo-a6303c9426a1ea3745b0e059b5d1f0a0703899ce.zip
dev-python/pytest-xprocess: fix broken tests
Closes: https://bugs.gentoo.org/664542 Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild')
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
index 8677f37ccd25..b749a2cba7df 100644
--- a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
@@ -24,9 +24,8 @@ RDEPEND="
DEPEND="${RDEPEND}"
python_test() {
- cd example || die
# Upstream's package mistakenly includes __pycache__ directory that make
# tests fail.
- rm -rf __pycache__ || die
+ rm -rf example/__pycache__ || die
pytest -v || die
}