summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-30 18:14:45 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-30 18:23:20 +0100
commit095d9de8e83661a96146fe5bca549bda922fcc00 (patch)
treea005b828ad261d2503d24dab790f1d2a7bad83c6 /dev-python/pytest-xprocess/pytest-xprocess-0.16.0.ebuild
parentdev-python/hypothesis: Bump to 5.41.0 (diff)
downloadgentoo-095d9de8e83661a96146fe5bca549bda922fcc00.tar.gz
gentoo-095d9de8e83661a96146fe5bca549bda922fcc00.tar.bz2
gentoo-095d9de8e83661a96146fe5bca549bda922fcc00.zip
dev-python/pytest-xprocess: Bump to 0.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess/pytest-xprocess-0.16.0.ebuild')
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.16.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.16.0.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.16.0.ebuild
new file mode 100644
index 000000000000..d9f406cc465b
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.16.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest