summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-09 09:27:45 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-09 12:49:41 +0100
commit0e64d72c10c2abf8a850b25d3a18ec2e7d901e28 (patch)
tree9d844cd9d0c699445dc1d7da809f9a306159a09d /dev-python/pytest-xprocess/pytest-xprocess-0.9.1.ebuild
parentdev-python/psutil: Add python3.5 support (diff)
downloadgentoo-0e64d72c10c2abf8a850b25d3a18ec2e7d901e28.tar.gz
gentoo-0e64d72c10c2abf8a850b25d3a18ec2e7d901e28.tar.bz2
gentoo-0e64d72c10c2abf8a850b25d3a18ec2e7d901e28.zip
dev-python/pytest-xprocess: New package written by me
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess/pytest-xprocess-0.9.1.ebuild')
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.9.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.9.1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.9.1.ebuild
new file mode 100644
index 000000000000..537acf1ce46d
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-xprocess/ https://bitbucket.org/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ PYTEST_PLUGINS="pytest_xprocess" py.test -v -v || die
+}